DeeEmm

Pragmatism in code

Waxing lyrical about life the universe and everything software related since lunchtime 2006.

Add Youtube video button to TinyMCE

Not strictly a Dolphin modification, as it applies to TinyMCE in general, but I will outline it here for Dolphin 7. It's a pretty easy modification to do, just two files to edit.

The functionality for this is already in TinyMCE, but for some reason it is not enabled. I've tested this out on version 7.0.2 with no issues.

To enable YouTube /flash video button in the forums

Edit

modules/boonex/forum/layout/base/xsl/canvas_init.xsl

Find the following line

theme_advanced_buttons3_add : "emotions,iespell,flash,separator,print",

Change it to...

 

theme_advanced_buttons3_add : "emotions,iespell,flash,separator,print,separator,media",

 

Now compile the forums, and you should see a new button

 

 

To enable YouTube /flash video button for the rest of the site

Edit...

/templates/base/scripts/BxBaseConfig.php
Find...
theme_advanced_buttons3_add : "emotions",
Replace it with
theme_advanced_buttons3_add : "emotions,separator,media",
This should add it into TinyMCE for the main areas of the site such as blogs etc.
 
 
To insert a youtube video
  • Copy the url from the video's page,
  • Click on the button in TinyMCE.
  • Select 'flash'
  • Paste URL into URL box
  • Click insert
Job Done!!

 

 

Dolphin - Flat comments mod updated
Dolphin - Remove big join button from promo

Related Posts

 

Comments 4

Mario Moreno on Tuesday, 26 October 2010 16:33

Deeemm. After doing this my photos and other images in my site get deleted or disappear! This also happened in 7.0.3. Any ideas in your free time?

0
Deeemm. After doing this my photos and other images in my site get deleted or disappear! This also happened in 7.0.3. Any ideas in your free time?
DeeEmm on Wednesday, 03 November 2010 03:48

Mnnnn, this should not happen as enabling the button is not related to image handling, it only enables the button to appear in the editor, it does not change any code related to image uploading.

which images dissappear? is it user avatars? if so there is a known bug that causes this to happen.

/DM

0
Mnnnn, this should not happen as enabling the button is not related to image handling, it only enables the button to appear in the editor, it does not change any code related to image uploading.

which images dissappear? is it user avatars? if so there is a known bug that causes this to happen.

/DM
Mario Moreno on Wednesday, 03 November 2010 17:47

still get that deleted images. dont know why.

here is a snapshot: [url]http://imm.io/1Uv0[/url]

User uploaded pics, polls, and site thumbs are gone.
I try to add a tiny mce plugin and this also happened. so its a big problem for me.

looks like as soon as i touch that BxBaseConfig.php file, my images are gone.

0
still get that deleted images. dont know why.

here is a snapshot: [url]http://imm.io/1Uv0[/url]

User uploaded pics, polls, and site thumbs are gone.
I try to add a tiny mce plugin and this also happened. so its a big problem for me.

looks like as soon as i touch that BxBaseConfig.php file, my images are gone.
DeeEmm on Wednesday, 03 November 2010 23:04

looks like a permissions issue to me. Have you checked that the images still exist?

0
looks like a permissions issue to me. Have you checked that the images still exist?
Already Registered? Login Here
Guest
Saturday, 19 August 2017
If you'd like to register, please fill in the username, password and name fields.

Captcha Image